Some storefronts are unavailable
Incident Report for Uscreen
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 16:06 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 09, 2024 - 16:05 UTC
Monitoring
A fix has been implemented by our 3rd party partner, DigitialOcean and we're seeing sites come back online.

Our team will continue to monitor.
Posted Oct 09, 2024 - 16:03 UTC
Update
We continue to monitor the situation with our 3rd party partner, DigitialOcean.

We will continue to update this incident.
Posted Oct 09, 2024 - 15:47 UTC
Update
Our 3rd party server provider, DigitalOcean, is investigating the issue on their end. We will continue to monitor the situation.

If your store is impacted, we highly recommend updating your DNS settings and migrating to our newer, more reliable servers.
Posted Oct 09, 2024 - 14:31 UTC
Identified
We're investigating an issue with our servers that may impact stores with outdated DNS records. Our team is working on a solution with our 3rd party partners.

We will continue to update this incident.
Posted Oct 09, 2024 - 13:06 UTC
This incident affected: Storefront.