Slow loading and 500 errors

Incident Report for Uscreen

Resolved

We’ve resolved the ongoing issues. We appreciate your patience while our team worked on this.
Posted Jul 31, 2024 - 14:08 UTC

Monitoring

We’ve deployed a fix, and we’re already noticing performance improvements. Our team will continue to monitor the situation closely.
Posted Jul 31, 2024 - 13:40 UTC

Identified

Our team has identified the root cause of the errors and is actively working on deploying a solution.
Posted Jul 31, 2024 - 13:34 UTC

Investigating

Our team is currently investigating slow loading of storefronts and 500 errors on the Admin portal.
Posted Jul 31, 2024 - 13:12 UTC
This incident affected: Admin Portal and Storefront.