Partial outage: delayed access granting after purchase

Incident Report for Uscreen

Resolved

This incident has been resolved.
Posted Aug 09, 2025 - 04:45 UTC

Monitoring

All systems have since recovered and are operating normally, the service was successfully scaled. We are monitoring the system.
Posted Aug 09, 2025 - 04:00 UTC

Identified

Our team identified a scaling issue of the background job processing system: more tasks were created than the job could process.
Posted Aug 09, 2025 - 03:15 UTC

Investigating

Some functionality such as granting access after a purchase or content moderation of newly uploaded videos is working with significant delays.
Posted Aug 09, 2025 - 03:00 UTC
This incident affected: Admin Portal and Storefront.