Error "Rate Exceeded"
Incident Report for Uscreen
Postmortem

We are sharing more details on the issue that happened on June 23rd, which affected the Uscreen Admin Area and some Uscreen websites. Between 01:25 and 01:45 UTC, our customers might have seen a “Rate exceed” message when trying to access the Uscreen Admin Area or their Uscreen website.

Summary of the Issue

The problem was caused by an enormous number of requests to our live chat service, which our system couldn’t handle due to previous scalability rules.

Preventive Measures

To prevent this from happening again, we have improved our scalability rules to handle loads similar to what we experienced during the issue.

We are sorry for any inconvenience this caused. Thank you for your patience and understanding.

Posted Jun 24, 2024 - 13:33 UTC

Resolved
The incident has been resolved. Thank you for your patience.
Posted Jun 23, 2024 - 02:14 UTC
Monitoring
A fix has been implemented and videos should now be loading properly. We'll continue to monitor.
Posted Jun 23, 2024 - 01:48 UTC
Identified
You might experience issues with live chat, the rest of the platform should work well.
Posted Jun 23, 2024 - 01:36 UTC
Update
We've identified the root cause of the issue and are preparing a quick fix. Thank you for your continued patience.
Posted Jun 23, 2024 - 01:32 UTC
Investigating
We are currently investigating an issue that is causing "Rate exceeded" errors when accessing the Uscreen Admin Area. We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve this issue. Thank you for your understanding.
Posted Jun 23, 2024 - 01:30 UTC
This incident affected: API (API V1, API V2) and Admin Portal, Storefront.