Errors In Video Playback

Incident Report for Uscreen

Resolved

The video playback issues have been fully resolved. Our CDN partner's fix has been successfully implemented, and we have confirmed that videos are functioning normally.
Posted Oct 03, 2025 - 15:08 UTC

Monitoring

Our CDN partner has implemented a fix for the video playback errors. We are currently monitoring to ensure videos are functioning normally. We will provide a final update once we confirm the issue is fully resolved.
Posted Oct 03, 2025 - 14:32 UTC

Identified

A third-party CDN partner is experiencing issues that are causing video playback errors. Some videos may not play as expected. We're in close communication with our CDN partner and will provide updates as we have them.
Posted Oct 03, 2025 - 13:48 UTC
This incident affected: Uscreen Video on Demand.