The video playback issues have been fully resolved. Our CDN partner's fix has been successfully implemented and we have confirmed that videos and livestreams are functioning normally.
Posted Sep 18, 2025 - 18:35 UTC
Update
Our CDN partner has implemented a fix for the video playback errors. We are currently monitoring to ensure videos and livestreams are functioning normally. We will provide a final update once we confirm the issue is fully resolved.
Posted Sep 18, 2025 - 17:39 UTC
Monitoring
Our CDN partner has implemented a fix for the video playback errors. We are currently monitoring to ensure videos and livestreams are functioning normally. We will provide a final update once we confirm the issue is fully resolved.
Posted Sep 18, 2025 - 17:39 UTC
Identified
Our CDN partner has identified the issue causing video playback errors. They are currently working on implementing a fix. Some videos and livestreams may still not play as expected while the fix is being deployed. We will continue to provide updates as we receive them.
Posted Sep 18, 2025 - 17:11 UTC
Investigating
A third-party CDN partner is experiencing issues that are causing video playback errors. Some videos and livestreams may not play as expected. We're in close communication with our CDN partner and will provide updates as we have them.
Posted Sep 18, 2025 - 17:09 UTC
This incident affected: Uscreen Video on Demand and Uscreen Live Streaming.